WightFibre - Service Outage 28/05/2026 - 09:30am – Incident details

No known issues

Service Outage 28/05/2026 - 09:30am

Resolved
Partial outage
Started 24 days agoLasted 11 minutes

Affected

Internet

Partial outage from 8:30 AM to 8:40 AM

Apse Heath area

Partial outage from 8:30 AM to 8:40 AM

Bembridge area

Partial outage from 8:30 AM to 8:40 AM

Brading area

Partial outage from 8:30 AM to 8:40 AM

Brighstone area

Partial outage from 8:30 AM to 8:40 AM

Cowes area

Partial outage from 8:30 AM to 8:40 AM

Updates
  • Resolved
    Resolved

    Description: We’re pleased to confirm that an earlier issue affecting broadband service has now been resolved. Our service partner has completed their work, and systems are operating normally again. If you experienced any disruption, services should now be restored automatically. There’s no action required from you. Should you continue to notice any issues, please restart your equipment and contact our Customer Service team if the problem persists. Thank you for your patience. WightFibre Customer Service Team

  • Investigating
    Investigating

    We are currently aware of an issue affecting services where some equipment may appear offline or not respond as expected. Our technical teams are actively investigating and are working closely with our service partner to identify the cause and restore everything back to normal as quickly as possible. During this time, some customers may notice intermittent service behaviour. We apologise for any inconvenience this may cause and want to reassure you that resolving this issue is our priority. Thank you for your patience and understanding while we work to resolve this issue. Best Regards, WightFibre Customer Service Team