WightFibre - Newport Service Outage - 31st July 2026 – Incident details

WightFibre TV experiencing degraded performance

Newport Service Outage - 31st July 2026

Resolved
Major outage
Started 21 days agoLasted about 3 hours

Affected

Internet

Major outage from 9:42 AM to 12:38 PM

Newport area

Major outage from 9:42 AM to 12:38 PM

Updates
  • Resolved
    UTC
    Resolved

    Following the earlier local power supply fault, mains power has now been fully restored to the network equipment serving the Newport area.

    All affected services should be operating normally. If you are still experiencing any issues with your connection, please try rebooting your WightFibre Hub.

    Our teams will continue to monitor the network to ensure services remain stable following the restoration of mains power.

    We apologise for the disruption this has caused and thank you for your patience whilst we've been working on restoring service.

    WightFibre Customer Service Team.

  • Update
    UTC
    Update

    We have now secured a generator and our engineers are on site setting it up to restore power to the affected network equipment.

    We expect affected broadband services to begin restoring shortly once the generator has been connected and tested. Our teams will continue to monitor the situation closely until normal mains power is restored.

  • Identified
    UTC
    Identified

    Our engineers have identified that this outage is being caused by a mains power fault in the local area. SSE are currently investigating the issue and working to restore power as quickly as possible.

    To help minimise disruption, we are actively exploring alternative options to restore service sooner, including arranging temporary generator power for the affected network equipment.

    Services will remain unavailable for affected customers until power is restored or a temporary solution can be implemented. We will continue to provide updates as soon as we receive further information.

  • Investigating
    UTC
    Investigating

    We are currently investigating a service issue affecting some Full Fibre Broadband customers in the area served by one of our network cabinets.

    Our engineers are on their way to the equipment location and are actively working to identify the cause of the problem and restore services as quickly as possible.

    At this time, some customers in the Newport locality may be experiencing a loss of service. We will continue to provide updates as soon as more information becomes available.