WightFibre - Apse Heath - Service Outage – Incident details
No known issues
Welcome to WightFibre's Network Status Page
Our Network Status Page gives you a quick and easy way to see how our services
are performing across the Island. Here you’ll find real-time updates on
broadband, phone and TV services, along with information about any known
issues or planned maintenance. It’s the fastest way to check whether a problem
you’re experiencing is already being investigated by our team.
If you’re having trouble but nothing is showing on the Status Page, we’re here
to help. You can
log a case through the My Account Portal or call our friendly Customer
Service team on 01983 242424.
Customer Service Opening Times:
Monday to Friday: 8am – 8pm
Weekends & Bank Holidays: 10am – 6pm
Apse Heath - Service Outage
Resolved
Major outage
Started about 2 months agoMay 31, 2026Lasted about 19 hoursMay 31, 202612:53 PMJune 01, 20267:35 AMUTC
Affected
Internet
Major outage from 12:53 PM to 7:35 AM
Apse Heath area
Major outage from 12:53 PM to 7:35 AM
Updates
Resolved
UTC
Resolved
UTC
Our engineering team have completed further work and the issue has now been resolved.
Thank you again for your patience during this period.
Best wishes
Customer Service Team
Investigating
UTC
Investigating
UTC
We are currently aware of a service outage affecting the Apse Heath area and are actively investigating the issue.
Our Networks team is working to resolve this as quickly as possible, and we will provide further updates as soon as more information becomes available.
Please accept our sincere apologies for any inconvenience caused, and we thank you for your patience.
Best wishes,
Customer Service Team