WightFibre - Cowes Area Service Outage – Resolved ✅ – Incident details

No known issues

Cowes Area Service Outage – Resolved ✅

Resolved
Partial outage
Started 4 days agoLasted less than a minute

Affected

Internet

Partial outage from 8:27 PM to 10:24 PM, No known issues from 10:24 PM to 8:27 PM

Cowes area

Partial outage from 8:27 PM to 10:24 PM, No known issues from 10:24 PM to 8:27 PM

Updates
  • Update
    UTC
    Update
    This incident has been resolved.
  • Resolved
    UTC
    Resolved

    Last night, customers in the Cowes area may have experienced a loss of service due to an unexpected power issue affecting local network equipment. 🔌

    Following investigation by our Network engineers, the fault was traced to a damaged electrical breaker within the cabinet, which had developed an internal fault. This prevented power from reaching the equipment and eventually exhausted the backup battery supply.

    Our Networks team worked quickly to identify the issue, called the on call electrician, got the faulty component replaced, and safely restored power. 

    The affected cabinet is now fully operational, services have been restored, and the backup batteries are recharging normally. 🛠️⚡

    We apologise for any inconvenience this interruption may have caused and would like to thank customers for their patience while the issue was investigated and resolved.


    Thank you for your patience and understanding while we worked to restore service.


    If you are still experiencing an issue, please call the Customer Service Team on 01983 242424

    Best Regards,
    WightFibre Customer Service Team